icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.jsresidency.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

中大奖彩票 www.041255.com-彩票长龙最长多少期| www.234323.com-如何戒掉彩票| www.330059.com-网上买时时彩的软件| www.434609.com-体彩金孔雀一等奖| www.550723.com-华夏彩票可靠| www.682970.com-网易彩票能买了吗| www.780199.com-长沙快三-| www.870685.com-刚力彩芽av-| www.975141.com-彩票查询七星彩今日| www.hj7.cc-安徽快三中奖奖金| www.tb65.com-福利彩票彩种有哪些| www.27hv.com-体彩票开奖号码| www.0007.online135彩票官方网站| www.7553.cn-规划竞彩-| www.32771.cc-彩票三d和尾图| www.85612.com-彩38源码下载| www.055962.com-双色球走势图彩经网| www.181980.com-那个快三平台稳定| www.273969.com-11选5彩票平台| www.388201.com-华彩大厦-| www.523506.com-彩票合买到底靠谱不| www.621038.com-万利彩票-| www.705517.com-体育足球彩票兑奖| www.797208.com-凤凤彩票-| www.879303.com-江苏快三下载软件| www.988590.com-好运彩票网-| www.gm4.com-福彩快3图表| www.ri73.com-开门彩预测-| www.18id.com-存10元送38彩金| www.558.red-开心鸿运彩票安全吗| www.8671.com-体彩福彩群-| www.57177.cc-排列三黑彩平台技巧| www.023023.com-福彩小图-| www.106345.com-彩票号码怎么选6位| www.183558.com-体彩官方彩票app| www.266762.com-时时彩追遗漏| www.394855.com-竞彩足球怎么看亚盘| www.527839.com-竞彩足球复式串关| www.624761.com-速8彩票是正规的吗| www.704277.com-万家彩手机app| www.790252.com-炫彩头像-| www.872914.com-福彩加盟电话多少| www.974254.com-七乐彩设奖方式| www.jp61.com-山东福彩下载安装| www.n44.net-快乐彩票靠谱吗| www.52wj.com-彩票都是什么时候开| www.0556.org-地主刘文彩童养小| www.9118.biz-精准资料彩民福利| www.51813.cc-分分彩计划一期| www.002211.com-苏州彩票店转让58| www.081044.cc-体彩排列3追加期| www.155176.com-足彩19044期| www.286999.com-玩百姓彩票-| www.379326.com-奥客彩票网m| www.506799.com-如何研究彩票规律| www.584185.com-彩神全国代理| www.662987.com-新时代彩票网| www.741255.com-577彩票平台好吗| www.821551.com-七星彩图-| www.896224.com-玩彩网官方-| www.984059.com-老猫看彩快讯77期| www.pl39.com-55128中国彩吧| www.8wh.com-鼎彩国际app| www.71yc.cc-喜乐彩票是什么意思| www.1528.biz-福彩彩经网-| www.9955.cc-天天彩票官网购买| www.57786.cc-我中了彩票网下载| www.021172.com-山西彩票网-| www.098458.com-中彩快三计划破解| www.172743.com-4s彩票藏宝阁| www.288077.com-福彩网合买骗局| www.375882.com-七星彩排列图| www.505312.com-博彩新骗局-| www.580619.com-福彩大小走势图| www.662450.com-乐玩彩票官网| www.780733.com-体彩5d推荐号| www.865559.com-胜负彩澳客网电脑版| www.933966.com-时时彩6码必赢| www.992501.com-七星彩多期怎么玩的| www.zg.cc-彩票技巧规律和口诀| www.pa41.com-买快三有赚钱的吗| www.04ao.com-快三全骰是什么意思| www.76wc.com-彩票开奘查讯| www.2201.vip-中国福利彩票3开奖| www.8327.xyz-香港挂牌彩图678| www.33211.com-彩票多久开一期| www.81238.com-268彩票网站| www.036025.com-体育彩票术语大全| www.189476.com-彩3彩票-| www.265908.com-网上彩票诈骗套路| www.366561.com-福利彩票双色球33| www.459515.com-360彩票官网下载| www.551321.com-四场进球彩投注比例| www.657752.com-网上彩运来app| www.732831.com-体育彩票走势图排五| www.811036.com-彩票科学投注法| www.886093.com-神州时时彩-| www.999987.com-快三是啥玩意| www.if6.cc-内蒙快三今天预测| www.pp25.com-彩民彩票app正规| www.00cb.com-乐透了彩票下载| www.69nr.com-彩票输了两万不甘心| www.1238.top-彩票豹子怎样的| www.9623.xyz-排三免费预测彩经网| www.53579.cc-海南私彩平台出租| www.97899.com-法乙足彩分析| www.061606.com-彩客竞彩彩票| www.169208.com-10分快三合法不| www.257989.com-彩先知10码10码| www.332182.com-彩票现在正常了吗| www.410074.com-幸运之彩是骗局吗| www.515512.com-什么网站买七星彩| www.586333.cc-福彩3d校长-| www.657461.com-中国福彩票中奖号| www.858345.com-玩高频彩的最高境界| www.926218.com-南昌体彩-| www.974652.com-七星彩开码结果查询| www.bo94.com-网易彩票应用软件| www.sj40.com-福彩快三属于哪个省| www.11pe.com-越南时时彩计划| www.81ag.com-财富彩票助手| www.1650.net-陕体彩11选5开奖| www.9710.org-类似彩宝彩票的软件| www.52889.cc-好彩香烟在哪里买| www.96155.com-微山南阳彩礼多少钱| www.055309.com-可以看快三的app| www.154853.com-怎么看足彩结果| www.236028.com-足球彩票19054| www.306026.com-六利彩开奖结果查询| www.374410.com-找个最可信的彩票网| www.512020.com-昆虫彩铅画-| www.581596.com-app购彩合法吗| www.651608.com-永利彩票怎么样| www.761003.com-秒速时时彩计划两期| www.843515.com-福彩会不会改制| www.909088.cc-澳门十二生肖彩| www.969971.com-3d图谜总汇牛彩九| www.cp6300.com-彩乐乐-| www.lg13.com-彩票界-| www.c64.me-中国彩票开奖情况| www.28ng.com-湖北有哪些彩票网站| www.0364.cc-彩票杀号技巧| www.6463.vip-彩票稳定回血的办法| www.12117.cc-17彩票官网-| www.52290.com-幸运中彩票安卓版| www.92345.cc-精彩彩票下载| www.050618.com-今日彩票报纸| www.168333.cc-1分快3彩票官网| www.248274.com-彩票开奖大全下载| www.317290.com-玩时彩输了六十万| www.380078.com-wangyi彩票-| www.517852.com-迷彩虎官方app| www.577633.com-福满天体彩店苹果| www.646727.com-赢彩彩票app苹果| www.748878.com-六罗彩宝典-| www.811259.com-彩票中奖概率表| www.876505.com-天下彩票之开奖结果| www.968949.com-彩金软手镯-| 彩82www.128368.com| www.ex87.com-彩票是否中奖查询表| www.us75.com-彩投美女骗局| www.78.win-香港六给彩开奖结果| www.60dh.com-现在结婚彩礼顺口溜| www.888.pink-手机版彩票苹果版|